wiki:Navodila/IzobrazevalnaVzpostavitev/WR741ND-v2
Last modified 23 months ago Last modified on 09/06/2015 08:19:53 PM

Navodila za ročno vzpostavitev routerja TP-Link WR741ND verzija 2.x

Ta navodila so zastarela in se več ne uporabljajo, glej: Kratka navodila.

Navodila so bila uporabljena v okviru delavnice brezžičnih omrežij na II. gimnaziji Maribor in delavnice brezžičnih omrežij v OpenLabu v Kranju.

Gradiva

Sledeča gradiva prenesi na svoj računalnik pred pričetkom praktičnega dela.

  • Prenesi in si shrani firmware wlan slovenija.
  • Prenesi in namesti WinSCP program, če uporabljaš Windows.
  • Prenesi program PuTTY, če uporabljaš Windows.
  • Registriraj se na bazi točk.
  • Generiraj referenčno konfiguracijo za tvojo točko.
    • Obišči stran za registracijo nove točke.
    • Node type izberi: Wireless node.
    • Project izberi glede na lokacijo, kjer boš postavil to točko.
    • Node name izberi po vzorcu: ulica-hišna števila (primer: krekova-11).
    • Obkljukaj Require direct connection to a VPN server.
    • Router type izberi: TP-Link WR741ND.
    • Izberi poljubno geslo ali pusti generiranega (priporočeno).
    • Potrdi Register.
    • Izberi Generate, obkljukaj Configuration only in daj Generate.
  • Na tvoj e-mail naslov se pošlje povezava do referenčne konfiguracije, prenesi jo na računalnik.

Navodila dosledno upoštevaj, vprašanja so seveda dobrodošla.

  • Prenesi vsa potrebna gradiva na svoj računalnik.
  • Izklopi WiFi povezavo in se z kablom poveži na router.
  • Prepričaj se, da imaš mrežni vmesnik nastavljen na DHCP.
  • Na http://192.168.1.1 se prijavi z admin/admin.
  • Izberi System tools in Firmware upgrade.
  • Izberi datoteko wlansi-delavnica-kr-firmware.bin na tvojem računalniku in potrdi Upgrade.
  • POZOR: Ne izklopi routerja med nadgradnjo!
  • Ko System (druga iz leve) lučka na routerju neprestano sveti lahko nadaljuješ.
  • Izklopi router.
  • Vklopi router, ko se SYS lučka prižge, drži QSS gumb za 3 sekunde, dokler SYS ne začne hitro utripati.
  • Poveži LAN port z računalnikom.
  • Nastavi mu statični ip 192.168.1.155/255.255.255.0.
  • Vzpostavi telnet povezavo na router:
    • IP: 192.168.1.1
    • Windows: PuTTY
    • Mac OS X in Linux: telnet 192.168.1.1 v terminalu
  • Poženi sledeče ukaze
    firstboot
    sync
    
  • Izklopi router in ga ponovno vklopi, ko SYS lučka preneha utripati ponovno vzpostavi telnet povezavo na router kot zgoraj.
  • Nastavi enako geslo, kot si ga izbral v referenčni konfiguraciji:
    root@OpenWrt:/# passwd
    Changing password for root
    New password: 
    Retype password: 
    Password for root changed by root
    
  • Onemogoči firewall:
    root@OpenWrt:/# /etc/init.d/firewall stop
    root@OpenWrt:/# /etc/init.d/firewall disable
    
  • Skopiraj razširjeno datoteko etc s scp na router:
    • Windows:
      • Zaženi WinSCP.
      • Hostname: 192.168.1.1
      • User name: root
      • Password: kar si nastavil
      • File protokol: SCP
      • Klikni Login
      • Ignoriraj napake.
      • Klikni ...
      • Vstopi v etc/
      • (S tem korakom počakaj na delavnici.) Skopiraj vsebino mape etc/, ki si jo dobil po emailu v referenčni konfiguraciji v etc/ na rotuerju.
      • Potrdi overwrite.
    • Mac OS X in Linux:
      hostname:~User$ scp -r Downloads/etc/ root@192.168.1.1:/
      
  • Vzpostavi SSH povezavo z routerjem (username: root, geslo: kot nastavljeno na bazi točk).
  • Zaženi sledeče ukaze:
    root@OpenWrt:/# chmod +x /etc/init.d/inituci
    root@OpenWrt:/# /etc/init.d/inituci enable
    root@OpenWrt:/# reboot && exit
    

Ali pa uporabiš kar ukaz v eni vrstici za vse:

chmod +x /etc/init.d/inituci && /etc/init.d/inituci enable ; reboot && exit
  • Točka se bo ponovno zagnala in povezala v omrežje, čez nekaj minut jo lahko vidiš že na bazi točk.
  • a točko se lahko povežeš brezžično ali dostopaš s statičnim IPjem.

SSH povezava na točko po vzpostavitvi

Ko je točka vzpostavljena v omrežje lahko na njo dostopaš preko SSHja, vendar moraš uporabiti drugačen IP.

  • Brezžično se poveži na točko (SSID: open.wlan-si.net).
  • Poišči IP svoje točke na bazi točk.
  • Vzpostavi SSH povezavo z izbranim programom.

Geslo lahko najdeš na spletni strani točke na bazi točk, če izbereš Edit node.

Uporaba statičnega IPja na WAN portu za priklop v domače omrežje

Statični IP na WAN portu za priklop v domače omrežje se skonfigurira tako, da se vzpostavi brezžična povezava na open.wlan-si.net omrežje in se preko SSH (s PuTTY ali konzolo) povežeš na router ter izvedeš sledeče ukaze. Vrednost ipaddr zamenjaj z željenim IPjem v domačem omrežju, ostale naslove pa tudi.

root@kozolec-wr741nd:~# uci set network.wan.proto=static
root@kozolec-wr741nd:~# uci set network.wan.ipaddr=192.168.1.34
root@kozolec-wr741nd:~# uci set network.wan.netmask=255.255.255.0
root@kozolec-wr741nd:~# uci set network.wan.dns=192.168.1.1
root@kozolec-wr741nd:~# uci set network.wan.gateway=192.168.1.1
root@kozolec-wr741nd:~# uci commit network
root@kozolec-wr741nd:~# ifup wan

Odpravljanje napake Clock out of sync

Napaka Node's local clock is more than 30 minutes out of sync! pomeni, da se router ni uspel sinhronizirati z časovnim strežnikom. Da odpraviš to napako moraš najprej vzpostaviti SSH povezavo na svoj router. To storiš tako, da se najprej brezžično povežeš na open.wlan-si.net in nato vzpostaviš SSH poveavo na IP tvoje točke, ki ga najdeš na bazi točk. Geslo za svoj router lahko najdeš, greš na stran svoje točke in izbereš Edit node.

Nato posodobiš seznam paketov za namestitev, ki so na voljo in namestiš paket ntpclient:

root@kozolec-wr741nd:~# opkg update 
root@kozolec-wr741nd:~# opkg upgrade ntpclient
root@kozolec-wr741nd:~# reboot

Nova konfiguracijska datoteka ne prepiše tastare ampak jo samo doda v conf s kratico opkg. Zato je treba staro premakniti in novo preimenovati. To storimo z naslednjimi ukazi:

root@kozolec-wr741nd:~# mv /etc/config/ntpclient /etc/config/ntpclient-cp 
root@kozolec-wr741nd:~# mv /etc/config/ntpclient-opkg /etc/config/ntpclient
root@kozolec-wr741nd:~# opkg update 

Vklop DHCPja na LAN vmesniku

Opisan postopek omogoča uporabo LAN vmesnika/porta z drugimi računalniki.

  • Na bazi točk izberi svojo točko in s funkcijo Add subnet dodaj podomrežje/subnet z privzetimi nastavitvami. Izberi Allocate.
  • Po potrditvi poišči na strani točke Subnets, eden izmed njih bo poimenovan LAN. Primer:
    10.254.154.192/27 LAN
    
  • Nato je potrebno urediti sledeče konfiguracije na routerju preko SSH povezave. Urejamo z urejevalnikom vi.
    • /etc/config/network
      • IP pri ipaddr mora biti za en IP večji kot LAN IP/27 zapisan na strani, netmask mora biti kot prikazano:
        config interface lan
                option ifname   eth0
                option proto    static
                option ipaddr   10.254.154.193
                option netmask  255.255.255.224
        
    • /etc/config/dhcp
      • V to config datoteko prekopiramo spodaj navedeno, start mora biti 2 IPja večji od LAN IP/27, limit pa 28 IPjev večji od LAN IP/27:
        config dhcp lan                    
                option interface lan
                option start 194    
                option limit 222    
                option leasetime 30m
                option force 1 
        
    • /etc/olsrd.conf
      • Pod prvo vrstico v oklepajih dodamo LAN IP/27 in netmask, kot prikazano:
        Hna4
        {
          10.254.153.96  255.255.255.224
          10.254.154.192 255.255.255.224
        }
        
    • /etc/config/routing
      • Dodamo vnos, kjer je option dest_ip enak LAN IP/27:
        config policy
                option dest_ip '10.254.154.192/27'
                option table 'main'
                option priority 999
        
  • Ponovno zaženemo router in počakamo nekaj minut, da se povezava vzpostavi.

POZOR: Preko lan vmesnika ne bo mogoče pingati routerja ali do njega dostopati preko SSHja, povezava v Internet bo delovala.

Vprašanja in naprej

Vsa vprašanja, željo po sodelovanju še naprej ... lahko nasloviš na poštni seznam, stopiš z nami v stik na klepetu ali po e-mailu.

Ponastavitev OpenWrt

S to metodo je mogoče ponastaviti nastavitve na default – stanje pred scp-janjem in zagonom ukazov. Uporablja se, če je v tem postopku šlo kaj narobe.

  • Vključi router v elektriko, ko se SYS lučka prižge, drži QSS gumb za 3 sekunde, dokler SYS ne začne hitro utripati.
  • Poveži LAN port z računalnikom.
  • Nastavi mu statični ip 192.168.1.155/255.255.255.0.
  • Poženi telnet na 192.168.1.1 in zaženi sledeče komande
    firstboot
    sync
    passwd
    
  • Z zadnjim ukazom ponovno nastaviš geslo na routerju. Nastavi enako, kot je zapisano v bazi točk za tvojo točko.

Popravek VPN nastavitev

V kolikor se pojavljajo izgube paketov preko VPN tunela je potrebno spremeniti MTU nastavitev. EDIT: Ta napaka je že odpravljena!

Le to se storiš tako, da spremeniš sledeč zapis v /etc/init.d/n2n kot prikazano in ponovno zaženi router:

edge -f $args -a $ipaddr -c $community -k $key -l ${supernode}:${port} 
//spremeni v
edge -M 1355 -f $args -a $ipaddr -c $community -k $key -l ${supernode}:${port} 

Attachments